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Abstract

To provide useful spectral wavelength information, a stellar spectrum must be

wavelength calibrated. This paper will discuss ways to use VSpec software to

wavelength calibrate a high resolution (2,400 lines/mm) stellar hydrogen alpha

spectrum. The paper will discuss using neon spectral lines to provide a linear

calibration. The use of atmospheric water absorption lines to create a non-linear

calibration will also be discussed. Finally the use of a heliocentric calibration will

be discussed. The resulting wavelength calibrated spectrum can be used to

determine radial velocities to a high degree of accuracy.
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I. Introduction

A spectrum created with a Lhires III or most other spectrographs is not linear. A 10Å profile linear width at one

end of the spectrum will have a different profile linear width at the other end. For high resolution spectra using a

2,400 lines/mm grating, the spectrum is close to linear. The lower the resolution, and thus wider the spectrum,

the more non-linear it becomes. For this reason neon line calibration works well for high resolution spectra, but

for the most accurate and for lower resolution calibration the use of water vapor atmospheric absorption lines

can provide an excellent non-linear calibration. For a linear calibration the Lhires III built-in Neon calibrator that

works well.

With photometry, a heliocentric correction is very important for short term variables stars. Depending on the

time of year and the star, a time difference of up to 16 minutes can exist due to where the Earth is in its orbit

around the Sun. This can be corrected so times are based on the center of the Sun using a heliocentric time. With

spectroscopy, the time difference is usually not important, but another difference is. Again, depending on the

time of year and the star, it is possible the Earth is moving toward that star at a maximum velocity or on the

opposite side of the orbit, away from the star. There is also a correction for the rotational velocity of the Earth.

The spectroscopic heliocentric correction adjusts for these and bases the motion to the center of the Sun.

This paper will discuss using the neon spectrum to do a linear wavelength calibration. Next, to refine that, a non-

linear calibration will be discussed using atmospheric H2O lines. Finally a Heliocentric calibration will be

discussed to account for the Earth�s motion. A comparison of the three calibrations will show the center

hydrogen α wavelength  after each calibration.

II. Taking the Spectrum

There are a couple of things to consider when taking the spectrum image.

1. Do not expose to exceed a maximum pixel ADU count of 32,000.

2. Orient the imaging camera so the spectrum is parallel to the bottom of the frame.

3. Save the image as a 16 bit signed FITS type file.

III. Software

There are several image processing programs than can be used to process spectrum images. For this paper,

VSpec is used. Iris is another program and can be used to preprocess the spectrum image. This will increase the

signal-to-noise, but can create problems with wavelength shifting. It is suggested that VSpec be used for

wavelength calibration and the spectrum preprocessed with Iris to straighten it, subtract the sky and optimize

the spectrum for further processing.



IV. Equipment

At the Hopkins Phoenix Observatory we use a Lhires III on a Meade 12� LX200 GPS SCT.

A Meade DSI Pro (I) CCD camera is used for guiding and a DSI Pro II CCD camera is used for the spectrum

imaging.

Lhires III with DSI Pro CCD Cameras on HPO 12" LX200 GPS

A note about VSpec. The profiles displayed in VSpec can have multiple layers. The top layer is called the

Intensity layer. When saving the profile, that is always the one saved, not necessarily the one being displayed.

In order to save a current profile, e.g., one that has just been calibrated, the current profile must replace the

Intensity or top profile and then it can be saved. A new name is used so it does not replace the original profile.



Inside The Lhires III

The top is coupled to the telescope (bronze color). To the upper right is a black tube that goes tot he guiding

camera. The lower right connection (red) goes to the imaging camera. A slivered slit reflects light for centering the

star in the slit. The micrometer (lower left) allows adjustment of the tilt of the diffraction grating to change the

spectral region being observed.



Neon Calibrator Circuit Board

The neon calibrator is installed inside the Lhires III above the slit. When turned on it causes the neon bulb to

light and illuminate the slit with neon radiation. The board is designed to work from 12 VDC, however the

circuitry can easily work at 18 VDC. Two 9 V batteries in series works well. The batteries can be attached to

the Lhires III to minimize cabling,



V. Linear Calibration With Neon

1. Introduction

The Lhires III makes taking a spectrum of a star is relatively easy. The challenging part comes with the

processing of the image. Fortunately there are several free software programs that can help with the processing.

These are French programs that have been translated (mostly). Iris can be used to preprocess a spectrum and

optimize it for import into VSpec. VSpec can then work its magic and calibrate and further process the data. A

built-in neon calibrator in the Lhires III spectrograph allows an easy means to take a spectrum of  neon at the

same settings as a star spectrum. As mentioned earlier this works well for high resolution spectra, but

decreasingly well the lower the resolution. The neon spectrum is taken with zero radial velocity so it provides

an excellent wavelength reference for the spectral lines.

2. Preferences

The first thing to do is to set two calibration frequencies in the program preferences. In this case we are

concerned with the hydrogen alpha (Hα) region so we select two prominent neon lines bracketing the center of

the hydrogen alpha line at 6,567.81 Å. Line 1= 6,532.98 Å and Line 2 = 6,598.95 Å

a.  From the Tool Bar "Options" menus select Preferences. and then. select the References tab.



b. For the Hα calibration set "Line 1:" to 6532.88

c. For the Hα calibration set "Line 2:" to 6598.95.

d. Select OK.

Note: Other preferences can be set at this time also if so desired.

3. Creating the Star Spectrum Profile

The star spectrum is a two dimensional image with a wide width and narrow height. The height is significant,

however. The reason is that the software can sum up all the ADU (Analog to Digital Units) counts of all pixels

in every column. This increases the signal-to-noise substantially.

a. From the "File" menu select Open Image and select the  star spectrum image. This should be a 16 bit

signed  FITS file. You will need to change the File Type in the "Open" window to see the FITS file.



Note: You may need to change the "File Type" to .fits in order to see the optimized files. There are several

types of FITS files, the spectroscopy programs work with the signed Integer version.

b. The star spectrum will display on the screen.

Note: This is a spectrum of Vega with 10-8 second exposures stacked with dark frames subtracted.

c. From the Tool Bar select the Display referenced binning zone icon.



d. A red rectangle will be displayed at the to of the screen. Drag it down until it encloses the spectrum.

Put the cursor in the middle of the red zone rectangle and note the X,Y  positions. The Y position is the one of

interest. In this case it is at 390, Make note of that.



e. From the Tool Bar select the Object binning icon. The program will bin or sum all the ADU counts for

each column of the spectrum image

f. A profile plot of the star's spectrum will be seen. This is the sum ADU counts for all the pixel columns (Y

axis) versus the wavelength (X axis).

4. Wavelength Calibration of the Spectrum Profile with a Neon Spectrum

Now import the spectrum of neon.

a. From the "File" menu select Open Image and select the neon spectrum file.



Note: The neon spectrum was 10-1 second exposures stacked with dark frames subtracted.

b. From the Tool Bar select the Display reference binning zone icon.



c. A red rectangle will be displayed at the top of the screen. Drag it down until it encloses the spectrum. at

he same position as the star spectrum, i.e., when Y = 390 with the cursor in the middle of the red zone

rectangle..

d. From the Tool Bar select the Reference binning icon.



e. The star spectrum profile will now have the two neon spectrum line profiles superimposed on the Vega

spectrum profile.

f. From the "Spectro" menu select Calibration 2 lines.



g. The star spectrum profile will be hidden and only the two neon line profiles shown. This is so the star

spectrum profile will not interfere with the neon calibration.

h. Use the cursor to click to the left of the left neon line and drag to the right to create an area of the first

neon line used to find the center for the calibration. The neon Line 1 wavelength (6,532.88 Å) will be displayed.

Select Enter.

i. Repeat for the second line (6,598.95). The select Enter again.



5. Neon Calibrated Profile

.The star profile will return and the neon line profiles hidden. The star spectrum is now wavelength calibrated.

To see the wavelengths and intensities go to the right and select the graduations icon.



Neon Calibrated Profile with Coordinates

6. Finding Wavelength

Use the cursor to determine the area center for the wavelength determination.



From the "Tools" menu select Label and the wavelength will be added to the profile with a vertical line showing

the measurement position of the center line.



The center of the neon calibrate Vega spectrum profile Hαααα line is 6,562.2612 Å

7. Normalizing the Profile

Until there is further calibration of the intensity it is usually easier to use a normalized intensity. The Intensity

Scale (Y axis) can be Normalized by selecting Normalize from the "Operations" pulldown menu.



Normalized Wavelength Calibrated Vega Spectrum Profile

8. Saving the Calibrated Profile

The resulting profile is now calibrated and normalized. It will turn purple. The profile can now be saved by

selecting Replace from the "Edit" menu and keeping the default Intensite selection then clicking OK. Now the

file can be saved. It is suggested a "Normalized" be added to the file name, e.g., VegaNormalized.spc.



VI. Non-Linear Calibration Using Atmospheric Lines

1. Introduction

Using atmospheric water vapor absorption lines (also known as the Telluric Lines) to do a non-linear calibration

works well if there is significant water vapor. Spectra taken a high elevations 10,000 feet and above may show

very little water vapor, however.

A Hα spectrum profile may contain many atmospheric H2O lines. It is possible to use those line to increase the

accuracy of the wavelength calibration.

2. Load Star Spectrum

Load an optimized star spectrum. Bin the spectrum to produce a profile.

3. H2O lines for the Calibration (Suggested).

Wavelength Intensity
6523.843 Å    300
6532.590Å    348
6534.000Å    155
6542.313Å    163
6543.907Å    515
6547.705Å    218
6548.622Å    378

Wavelength Intensity
6552.629Å    450
6557.171Å    251
6568.806Å    113
6572.072Å    338
6574.847Å    489
6580.786Å    138
6586..596Å    183

4. Selecting H2O Lines

From the tool bar "Tools" menu select Elements.



5. Identifying the lines

A window called "Elements" will be displayed. There are thousands of wavelengths listed, but we are only

interested in the atmospheric wavelengths so we must narrow the choice. From the "Line" box (upper right

corner) pull down and select atmos. Just those atmospheric lines will be displayed.

6. Setting the Multiple Line Calibration

From the tool bar "Spectro" menus select Calibration multiple lines.



7. Non-Linear Calibration Window

A "non-linear calibration" window will be displayed. Use the default "Degre 3." An equation up to 4th degree

can be generated, however, the default 3rd degree equation works well.



8. Identifying the  H2O lines

Sample Profile Showing Atmospheric Lines

Finding the correct H2O lines may seem a daunting task at first, but using the above image makes it easier.



9. Selecting the Lines

On the star spectrum profile select the first line by moving the cursor across it to identify the area of interest.

10. Logging the Lines

In the "Elements" window under "Lambda" click on the corresponding wavelength.

Then hit Enter. That wavelength value will display on the profile plot along with a "1" for the first line. That

wavelength value will also appear in the "Non linear calibration" window Lambda list. Repeat steps 9 - 10 for

the remaining H2O lines.



 

11. Determining the Equation

Once all the desired lines have been identified, in the "Non linear calibration" window (upper right) click on

Calcul.

The lower portion of the "non linear calibration" window called "Interpolation" will display coefficients to the

3rd degree for an equation for the calibration.



12. Applying the Equation

Select the Apply Eq and the profile will be calibrated.

13. Results

The fit is calculated and the residual errors (d_lambda) displayed. These will usually be less than the equivalent

of 1 pixel (in this case <0.1Å) and mostly significantly smaller. If not, look at the offending points to see what

might be wrong.

14. Saving the Equation and Lines

Save the list of wavelengths (Next time you record spectra in  the same wavelength zone, you can load these

directly instead of selecting them from the elements list).

Save the calculated calibration equation. (This equation will be the same for spectra in this wavelength zone as

long as you do not alter the spectrograph internals. This means in future you can use the equation plus just one

known point (e.g., a neon line) to get a good calibration when measuring the same wavelength zone.

15. Calibrated Profile

The star spectrum is now wavelength calibrated. To see the wavelengths and intensities go to the right and select

the graduations (top) icon.



Calibrated Profile with Coordinates

16. Normalizing the Profile

The Intensity Scale (Y axis) can be Normalized by selecting Normalize from the "Operations" pulldown menu.



Normalized Calibrated Vega Spectrum Profile

17. Saving the Calibrated Profile

The calibrated profile can now be saved by selecting Replace from the "Edit" menu and keeping the default

Intensite selection then clicking OK. Now the file can be saved. It is suggested a "H2O" be added to the file

name, e.g., VegaH2O.spc.



18. Overlaying the H20 Lines

Overlay the atmospheric lines again to demonstrate the improvement in fit and save your H20 calibrated result

as an .spc file. To do this click Export in the "Elements" window.



VII. Heliocentric Correction

1. Introduction

The Earth is spinning on its axis at about 1,042 miles per hour at the equator. At 33 degrees latitude our

rotational velocity is the cosine of the latitude times the equatorial velocity or about 874 miles per hour

(equatorial velocity times the cosine of the latitude). The Earth is also in orbit around the Sun traveling at about

67,000 miles per hour. Because of these motions it is important to make a correction for Doppler shift caused

by the radial motion of the observer relative to the star. To "zero out" this motion, positions are referenced to

the center of the Sun (heliocentric). Depending where we are in orbit, the time , date and the observer's latitude

the Doppler shift can be from zero up to a maximum depending on where the observed star is.

VSpec can handle all the calculations required to determine the Doppler shift after the observer's latitude,

longitude, date, universal time, the star's right ascension and declination have been entered.

2. Setting the Observer's Location

From the "Options" menu select Preferences...

Enter the observer's latitude and longitude as well as the Time Zone.



3. Entering the Star, Date and Time Information

From the "Spectrometry" menu select Heliocentric Correction.

Enter the star's right ascension (Alpha) and declination (Delta) as well as the Date and time. The year and

month (mm) are straight forward, but the day is the UT day with the time a decimal addition (part of a day).

For this observation the date and time were 22 June 2008 at 11:28 UT. For the day the first part is 22 and the

decimal part is 11.4667/24 or 22.47.



4. Calculating the Doppler Shift

Once the data has been entered into the "Heliocentric" window, select Compute. The :Infos..." window will

then display showing several calculated items.

JD = 2,454,639.972698
λλλλ    Correction = 0.069 Å

Air Mass = 1.2907

5. Adjusting the Profile

To adjust the profile, load a previously corrected profile (neon or H2O calibrated) and then from the

"Operations" menus select Translate. The "Translate" allows you to adjust the position of the profile relative

to the X axis wavelength.



6. Entering Correction
Enter the λλλλ Correction, in this case 0.069Å. Then select Apply.

7. Saving the Final Corrected Profile

As before, the current profile must replace the Intensity profile and then can be saved.

Final Calibrated Profile Center Line at 6,562.3847 Å



VIII. Comparing Wavelength Calibrations

Now that we have three levels of calibration it would be of interest to see how the different calibrations affects

Vega's spectrum profile wavelength. The center of the Hα line at each stage of the calibrations is used as a

reference.

As a comparison to an all VSpec neon calibration a preprocessed spectrum using Iris to subtract the sky, correct

tilt/slant and optimize the spectra was also done . The resulting calibrated center of the Hα line of the

preprocessed spectra is presented for comparison. While the preprocessed spectrum is off about 2 Å from the

other calibrated spectra, it does produce a better signal-to-noise ratio profile and works fine with the H2O and

Heliocentric calibrations.

                                 
           Preprocessed Neon       Neon Calibration         H2O Calibration        Heliocentric Calibration

Calibration Type Center of Hαααα Wavelength

Preprocessed Neon Calibration 6,564.5268 Å

VSpec Neon Calibration 6,562.2612 Å

H2O Calibration 6,562.2959 Å

Heliocentric H2O Calibration 6,562.3847 Å



IX. Comparing Preprocessing With All VSpec

PreProcessing with Iris to correct tilt/slant (if needed), subtract the sky and optimize the image will produce the

best signal-to-noise ratio for the spectrum image. Care must be taken when doing the neon calibration as the

preprocessing may introduce a shift and therefore significant wavelength error.

VSpec Only - No Preprocessing

Preprocessed with Sky Subtracted (Iris)

Preprocessed with Sky Subtracted and Optimized (Iris)

Note: All the above profiles use the same spectrum image.


